Help Desk Wiki

Help Desk Wiki » FAQs » SafariBrowserRequirements

Safari Browser Requirements

Below you will find configuration settings for Safari 3 & 4. These settings provide the best user experience for the myUFL system (my.ufl.edu) and ensure all portal services will work as expected. Microsoft Internet Explorer version 7 and up are the only officially supported Browsers. This upgrade is a first step in preparing for the financial upgrade that will occur in spring 2011.

Disabling the Popup Blocker

  • Select the 'Safari' menu located at the upper right hand corner of your screen
  • Select 'Preferences'
  • Select the 'Security' tab
  • Uncheck the box next to 'Block pop-up windows'

Deleting Cache and Cookies

  • Select the 'Safari' menu located at the upper right hand corner of your screen
  • Select 'Empty Cache'
  • When asked if you are sure you want to empty the cache select the 'Empty' button
  • Select the 'Safari' menu located at the upper right hand corner of your screen
  • Select 'Preferences
  • Select the 'Security' tab
  • Select the 'Show Cookies' button
  • Select 'Remove All'
  • Select 'Done'
  • Close and re-open the browser

Back to myUFL FAQ


Employee LoginViewPrintTalk

Home

Contact Us

Web: UF Computing Help Desk
Walk-in: HUB 132
Phone: (352) 392-HELP (4357)
Email: helpdesk@ufl.edu

Ask A Question

Submit a Question

Services

eLearning Support, Application Support Center

Self-Help

Help Desk Wiki, FAQ, Online Handouts, What's my UFID?

System Alerts

UF IT Dashboard Alerts (myUFL, Email, Network, etc)

Search